<< 【復旧】SFTPによるデプロイができない障害が発生しております | main | 【完了】緊急メンテナンスのお知らせ (ダッシュボードへのログイン) >>

2016.04.26 Tuesday

SqaleがPHP 5.5.34, 5.6.20 に対応しました!

SqaleがPHP 5.5.34, 5.6.20 に対応しました!
たいへんお待たせ致しました。リリース情報は以下のようになります。

PHP5.4以下の公式サポートは終了しました。PHP5.5以上のご利用を推奨いたします。

SqaleでPHP 5.5.34, 5.6.20 を利用するには

SqaleのPHPアプリケーションは、標準状態ではPHP 5.6.20 を利用する設定になっています。
新しいバージョンのPHPを利用する場合は、以下のマニュアルページに従ってPHPのバージョンを切り替えてください。

PHP 5.5.34, 5.6.20へバージョンアップ時のTips

Array are not allowed in the global sectionというERRORが発生する

ERROR: [/var/sqale/etc/php-fpm.d/env.conf:1] Array are not allowed in the global section のようなエラーが発生した際は、php-fpm.d/env.conf の記法を以下のように修正して下さい。 PHP 5.4.27 以降の clear_env 設定項目の追加によるものです。 php-fpm.conf のグローバル設定項目

修正前
ENV[foo] = 'bar'
修正後
[www]
ENV[foo] = 'bar'